No touchscreen after sleeping (Acer Spin 512 GeminiLake)

Hi,
Skip the long intro if you don’t feel like reading it :slight_smile:


first of all, thanks mr chromebox for this amazing project
I am a long term google “avoider”, user of degoogled lineageOS, previously cyanogenmod for a decade, and linux user.
Came across some refurbished chromebooks for 50EUR on amazon and had to give it a go when I saw google OS can be completely wiped out :slight_smile:
So I got my hand on Acer R851TN (Spin 512) - SPARKY360 board, Intel Geminilake chipset.

[USEFUL TIP] I had problems removing hardware write protect, the laptop would not boot with battery disconnected. I could only boot with ESC + search + power, and get to a screen saying chromeos is damaged and needs repair, but there was no options to do anything there except change the language.
Finally I decided to yank out the battery while the machine is live, booted and connected to power. risky yeah, but considering I hate google and it was only 50EUR, what the heck - and it worked like a charm!


And here we are on Ubuntu 23.10. (With clean uefi bios, no legacy no chromeos, done yesterday, so latest version)
Everything works great, except touchscreen dies after waking up from standby.
The only way to recover from it is reboot
Looking for any advice/workaround, like restarting some service, scripting something, disabling enabling etc…thanks!

EDIT: now I realized you guys don’t really recommend ubuntu, so I might give it a go with Fedora, assuming everything works (better) then on ubuntu for chromebooks…
But it’s puzzling how ubuntu has audio straight away, where most of the recommended distributions require some patching for audio…

Only Debian requires a custom kernel for working audio. And it’s highly recommended that you run the audio script on all distributions, for example you’ll quickly find you don’t have a working mic right now.

thanks, I run the audio script.

https://wiki.archlinux.org/title/Lenovo_ThinkPad_X1_Yoga_(Gen_3)#Fix_touchscreen_after_resume

This is the exact problem I have. Now, under the asumption I also have a bug in the firmware/bios that causes this, then maybe changing the distro to fedora or arch won’t help me.

I would like to try the solution proposed in this article above. I have installed acpi-call, but when I try to manually execute c ‘\_SB.PCI0.LPCB.EC._Q2A’ i get AE_NOT_FOUND
how can I list all valid acpi calls on my machine and try to identify the one for touchscreen?

hello,
i have installed Fedora and I have the exact same problem (no touchscreen after wake up from sleep)
I suspected this will be the case as it sounds like firmware bug, considering the information from arch forum for lenovo laptop that I linked above.

So, still looking for a solution/workaround. Nobody has this issue?

got this with acpidump

    Scope (\_SB.PCI0.I2C7)
    {
        Device (D039)
        {
            Name (_HID, "RAYD0001")  // _HID: Hardware ID
            Name (_UID, Zero)  // _UID: Unique ID
            Name (_DDN, "Raydium Touchscreen")  // _DDN: DOS Device Name
            Method (_STA, 0, NotSerialized)  // _STA: Status
            {
                Return (0x0F)
            }

            Name (_CRS, ResourceTemplate ()  // _CRS: Current Resource Settings
            {
                I2cSerialBusV2 (0x0039, ControllerInitiated, 0x00061A80,
                    AddressingMode7Bit, "\\_SB.PCI0.I2C7",
                    0x00, ResourceConsumer, , Exclusive,
                    )
                Interrupt (ResourceConsumer, Level, ActiveLow, Shared, ,, )
                {
                    0x00000075,
                }
            })

trying to figure out the magic acpi-call string that would wake my touchscreen device up

after trying debian, arch, fedora and ubuntu, i finally (unfortunately) settled with windows11 and everything works there in regards to sleep, wakeup and touchscreen