Need little info about FW restoration and FPR working

Restored original firmware from a backup.
However during restore process , i receive a message that WP cannot be enabled and maybe i have to restore with battery disconnected.

ChromeOS starts fine but fingerprint reader is not working.
WP is still disabled. Maybe FPR is connected with the WP disabled.

How to enable WP ?

hp elite c1030 jinlon

This is what i get with disconnected and connected battery.

WP always disabled

Ok:

$ sudo -i
$ flashrom --wp-status
$ flashrom --wp-enable

fixed the WP status, however fingerprint reader still not working, was working just fine before installing UEFI fw :frowning:

Found the following:

2024-02-28T13:34:07.199603Z INFO bio_fw_updater[1010:1010]: [biod_version.h(14)] vcsid 0.0.1-r3096-e1982d8268
2024-02-28T13:34:07.213479Z INFO bio_fw_updater[1010:1010]: [update_utils.cc(59)] Identified fingerprint board name as ‘bloonchipper’.
2024-02-28T13:34:07.213544Z INFO bio_fw_updater[1010:1010]: [update_utils.cc(74)] Found firmware file ‘/opt/google/biod/fw/bloonchipper_v2.0.4277-9f652bb3-RO_v2.0.23521-642195b-RW.bin’.
2024-02-28T13:34:07.213977Z INFO bio_fw_updater[1010:1010]: [bio_fw_updater.cc(42)] FWFile RO Version: ‘bloonchipper_v2.0.4277-9f652bb3’
2024-02-28T13:34:07.213990Z INFO bio_fw_updater[1010:1010]: [bio_fw_updater.cc(43)] FWFile RW Version: ‘bloonchipper_v2.0.23521-642195b’
2024-02-28T13:34:07.214003Z ERROR bio_fw_updater[1010:1010]: [cros_fp_updater.cc(112)] Failed to open fingerprint device, while fetching version.
2024-02-28T13:34:07.214034Z INFO bio_fw_updater[1010:1010]: [bio_fw_updater.cc(179)] Failed to fetch EC version, aborting.

:link: cros_fp_panicinfo

:link: cros_fp_panicinfo Unable to establish host communication
Couldn’t find EC

the only time I’ve run into the FPR not working was if the CCD settings were non-default, IIRC.

also, simply running flashrom --wp-enable doesn’t do anything without a range/region set. you have to set the RO region as protected before re-enabling software WP

1 Like

Is FPR related somehow with WP ?

it shouldn’t be but it’s been a while since I ran into this and don’t recall 100%