HP c645 G2 (NIPPERKIN) showing as Acer Spin 514 (DEWATT) in MrChromebox's firmware utility script

Hi all - new to this but enjoying the journey and learning. Using the instructions provided I was able to install Fedora 39 on my HP c645. Everything works but the trackpad (potentially related) - so far, still unsuccessful. As part of trying to fix this, I went to update/reinstall the MrChromebox firmware. Unlike when I originally updated to custom firmware when it showed the correct board information, this time, it shows the wrong board/computer. I’m curious if this why I’m running into problems and unsure how to proceed.

Any help is appreciated and thank you MrChromebox.

Most probably a bug with MrChromebox’s script

Hmm, that’s a bit odd. I might page @MrChromebox here just to see if it is an issue with the script.

what OS are you currently running?
what does my script show currently?
what does sudo dmidecode -t 0 show for the device name?

Thank you both (@s31bz & @MrChromebox).

I restored to stock and ran through the process again.
While running your script, it shows:
Device: HP Elite c645 G2 Chromebook (NIPPERKIN)
Platform: AMD Cezanne
Fw Type: Stock ChromeOS w/RW_LEGACY
Fw Ver: Google_Nipperkin.14500.358.0 (03/30/2023)

I run Option 2, installing (coreboot_edk2-nipperkin-mrchromebox_20240223.rom)

Once that is complete, it shows the same info as above with the exception of:
Fw Type: Full ROM / UEFI (pending reboot)

I reboot the device and see the coreboot logo.

I select Start Fedora-Workstation-Live 39.
Before installing Fedora, this is what I see:
entering - sudo dmidecode -t 0 results in:
(#) dmidecode 3.4
Getting SMBIOS data from sysfs.
SMBIOS 3.0.0 present.

Handle 0x0000, DMI type 0, 26 bytes
BIOS Information
Vendor: coreboot
Version: MrChromebox-4.22.2-5-g822782a1001
Release Date: 02/13/2024
ROM Size: 16 MB
Characteristics:
PCI is supported
PC Card (PCMCIA) is supported
BIOS is upgradeable
Selectable boot is supported
ACPI is supported
Targeted content distribution is supported
BIOS Revision: 4.22
Firmware Revision: 0.0

The live system I am running is Fedora 39 (Workstation Edition), Kernel Version: Linux 6.5.6-300.fc39.x86_64

I ran the MrChromebox script again and this is what is shows:
Device: Acer Chromebook Spin 514 (DEWATT)
Platform: AMD Cezanne
Fw Type: Full ROM / UEFI
Fw Ver: MrChromebox-4.22.2-5-g822782a1001 (02/13/2024)
Upgrade Available (02/23/2024)

I’m hesitant to select Option 1 and update since a different computer is showing. This seems to be the same result when I install the OS to the internal storage.

One other note, my trackpad does not work. Previously, when I restored to stock ChromeOS, it worked, but upon this restore, it does not. I am not sure if it is related.

Thanks for your help!

the nipperkin config was wrong, was building using the dewatt image. I’ve corrected the issue and updated the image. If you flash from ChromeOS now, it will flash the updated/corrected image and should properly identify after flashing in the UEFI settings and under Linux

1 Like

Thank you! I will run through the process tonight. Appreciate the prompt support!

Thank you @MrChromebox - when running your script, it displays the correct device.

Still sorting the trackpad but everything seems to work well.

Trackpad was a hardware (ribbon cable) issue. Fixed.

1 Like