Can't switch to developper mode

To be clear this is not a school chromebook its my personal chromebook.
Can’t switch to developper mode via recovery mode. I reach the recovery mode screen but Ctrl + D does nothing and neither Ctrl+ L or ctrl alt D. Tried both ctrl and alt. The key are not dead. Tried powerwash, tried developper branch build. the battery is unplug too.

126.0.6478.13 (Build officiel) dev (64 bits)
Révision d45f07771be6ef0ccae6e704daa9c448e6a5aeba-refs/branch-heads/6478@{#250}
Plate-forme 15886.8.0 (Official Build) dev-channel coral
Version du micrologiciel Google_Coral.10068.113.0
ID de la personnalisation RABBID
ARC 11836292 Version du SDK : 28
JavaScript V8 12.6.228.5
Agent utilisateur Mozilla/5.0 (X11; CrOS x86_64 14541.0.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/126.0.0.0 Safari/537.36

Ctrl + D. Press enter when asked, wait the white screen to come up and Ctrl + D again.

If it gives a bunch of black text on the developer mode screen and says it’s disabled at the top right corner that means the device was in fact enrolled and you need to contact whoever has it enrolled. If possible and available you attempt to use a SHIM image.

Try using an external keyboard to press CTRL + D. You won’t be able to hit enter with the external KB, but hopefully enter on the internal KB will work once you’re there.

Sometimes pressing the developer keys (Ctrl + D, enter) a bunch it will suddenly work.

Is this a 2-in-1 model? I have had a lot of issues with these and sometimes disconnecting the sensor will help or reinserting it.

Also, I would leave the battery plugged in until you are in developer mode.